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Product Overview

In this section...

“Ensures Software Reliability” on page 1-2
“Decreases Development Time” on page 1-2

“Improves the Development Process” on page 1-3

Ensures Software Reliability

You can ensure the reliability of your C++ applications by using PolySpace®
verification software to prove code correctness and identify run-time errors.
Using advanced verification techniques, PolySpace software performs an
exhaustive verification of your source code.

Because PolySpace software verifies all possible executions of your code, it
can identify code that:

e Never has an error

® Always has an error

® [s unreachable

® Might have an error

With this information, you can be confident that you know how much of your

code is run-time error free, and you can improve the reliability of your code
by fixing the errors.

Decreases Development Time

Using PolySpace verification software reduces development time by
automating the verification process and helping you to efficiently review
verification results. You can use it at any point in the development process,
but using it during early coding phases allows you to find errors when it is
less costly to fix them.

You use PolySpace software to verify C++ source code prior to compilation.
To verify the source code, you set up verification parameters in a project, run



Product Overview

the verification, and review the results. This process takes significantly less
time than using manual methods or using tools that require you to modify
code or run test cases.

A graphical user interface helps you to efficiently review verification results.
Results are color-coded:

® Green indicates code that never has an error.

® Red indicates code that always has an error.

® Gray indicates unreachable code (dead code).

® Orange indicates unproven code (code that might have an error).

This color-coding system helps you to identify errors quickly. You will spend

less time debugging because you can see the exact location of an error in the
source code. After you fix errors, you can easily run the verification again.

Using PolySpace verification software helps you to use your time effectively.
Because you know which parts of your code are error-free, you can focus on
the code that has definite errors or might have errors.

Reviewing the code that might have errors (orange code) can be
time-consuming, but PolySpace software helps you with the review process.
You can use filters to focus on certain types of errors or you can allow the
software to identify the code that you should review.

Improves the Development Process

PolySpace software makes it easy to share verification parameters and
results, allowing the development team to work together to improve product
reliability. Once verification parameters have been set up, developers can
reuse them for other files in the same application.

PolySpace verification software supports code verification throughout the
development process:

¢ An individual developer can find and fix run-time errors during the initial
coding phase.

® Quality assurance can check overall reliability of an application.

1-3
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® Managers can monitor application reliability by generating reports from
the verification results.
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Product Components

Product Components
The PolySpace products for verifying C++ code are combined with the
PolySpace products for verifying C code. These products are:
PolySpace® Client™ for C/C++
PolySpace® Server™ for C/C++

The user interface includes:

® The Launcher for setting up verification parameters and starting
verifications.

® The Viewer for reviewing verification results.

® The Spooler for managing verifications that run on a server and
downloading results from a server to a client.

1-5
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Installing PolySpace Products

In this section...

“Finding the Installation Instructions” on page 1-6

“Obtaining Licenses for PolySpace® Client for C/C++ and PolySpace® Server
for C/C++ Products” on page 1-6

Finding the Installation Instructions

The tutorials in this guide require both PolySpace Client for C/C++ and
PolySpace Server for C/C++ products. Instructions for installing PolySpace
products are in the PolySpace Installation Guide. Before running PolySpace
products, you must also obtain and install the necessary licenses.

Obtaining Licenses for PolySpace Client for C/C++
and PolySpace Server for C/C++ Products

See “PolySpace License Installation” in the PolySpace Installation Guide for
information about obtaining and installing licenses for PolySpace products.
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Working with PolySpace Software

In this section...

“Basic Workflow” on page 1-7
“The Workflow in This Guide” on page 1-8

“Working with PolySpace Project Model Files” on page 1-9

Basic Workflow

The basic workflow for using PolySpace software to verify C++ source code is:

Setup project

Verify code

3
Review verification results

In this workflow, you:

1 Use the Launcher to set up a project file.
2 Verify code on a server or client.

You can use the Launcher to start the verification or you can select files
from a Microsoft® Windows® folder and send them to thePolySpace software
for verification. For verifications that run on a server, you can use the
Spooler to manage the verifications and download the results to a client.

3 Use the Viewer to review verification results.
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The Workflow in This Guide

The tutorials in this guide take you through the basic workflow, including the

different options for running verifications. The workflow that you will follow
in this guide is:

Create new project

Verify code

-

3
Review verification results

In this workflow, you will:

1 Create a new project that you can use for the other steps in the workflow.
This step is in the tutorial Chapter 2, “Setting Up a Project File”.

2 Verify a single class using demo C++ source code.
This step is in the tutorial Chapter 3, “Running a Verification”. In this

tutorial, you will verify the same class using three different methods for
running a verification. You will:

e Use the Launcher to start a verification that runs on a server.
e Use PolySpace In One Click to start a verification that runs on a server.

e Use the Launcher to start a verification that runs on a client.

3 Review the verification results.

This step is in the tutorial Chapter 4, “Reviewing Verification Results”.
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Working with PolySpace Project Model Files

A PolySpace project model file is a project file that includes generic target
processor information. You can use this file to share project information,
but you cannot use it to run a verification. The tutorial Chapter 6, “Using a
PolySpace Project Model File” shows you how to work with PolySpace project
model files.
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Learning More

In this section...

“Product Help” on page 1-10
“The MathWorks Online” on page 1-10

Product Help

To access the help that came with your installation, select Help > Help or
click the Help icon in the PolySpace window.

To access the online documentation for PolySpace products, go to:
/www.mathworks.com/access/helpdesk/help/toolbox/polyspace/polyspace.html
The MathWorks Online

For additional information and support, see:

www.mathworks.com/products/polyspace
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Related Products

Related Products

In this section...

“PolySpace Products for Verifying C Code” on page 1-11
“PolySpace Products for Verifying Ada Code” on page 1-11

“PolySpace Products for Linking to Models” on page 1-11

PolySpace Products for Verifying C Code

For information about PolySpace products that verify C code, see the following:
http://www.mathworks.com/products/polyspaceclientc/
http://www.mathworks.com/products/polyspaceserverc/

PolySpace Products for Verifying Ada Code

For information about PolySpace products that verify Ada code, see the
following:

http://www.mathworks.com/products/polyspaceclientada/
http://www.mathworks.com/products/polyspaceserverada/

PolySpace Products for Linking to Models

For information about PolySpace products that link to models, see the
following:

http://www.mathworks.com/products/polyspacemodelsl/

http://www.mathworks.com/products/polyspaceumlrh/
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About This Tutorial

In this section...

“Overview” on page 2-2

“Example Files” on page 2-2

Overview

You must have a project file before you can run a PolySpace verification of
your source code. In this tutorial, you will create a project that you can use to
run verifications in later tutorials.

Example Files

In this tutorial, you will verify the class MathUtils in the source file
training.cpp that comes with the PolySpace installation CD. You can learn
more about the files and directories required for this tutorial in “Preparing
the Project Directories” on page 2-4.



Creating a New Project

Creating a New Project

In this section...

“What Is a Project?” on page 2-3

“Changing the Default Directory” on page 2-8

page 2-10

“Preparing the Project Directories” on page 2-4

“Opening the PolySpace Launcher” on page 2-5

“Creating a New Project to Verify a Class in the Training C++ File” on

What Is a Project?

In PolySpace, a project is a named set of parameters for a verification of your

software’s source files. A project includes:

e The location of source files and include directories

¢ The location of a directory for verification results

® Analysis options

You can create your own project or use an existing one. You can create and
modify a project using the Launcher graphical user interface.

A project file has one of the following file types:

Project Type File Extension

Description

Configuration cfg

Required for running a
verification. Does not
include generic target
processors.

2-3
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Project Type File Extension Description
PolySpace Project ppm Used to populate a
Model project with analysis

options, including
generic target
processors.

Desktop dsk Obsolete. Used in
earlier versions of
PolySpace software for
running a verification
on a client computer.

In this tutorial, you create a new project and save it as a configuration file
(.cfg).

Preparing the Project Directories

Before you start verifying C++ code with PolySpace software, you must know
the locations of the C++ source file and the include files. You must also know
where you want to store the verification results.

For each project, you decide where to store source files and results. For
example, you can create a project directory and then create separate
directories for the source files, include files, and results within the project
directory.

For this tutorial, prepare a project directory as follows:

1 Create a project directory named polyspace_project.

2 Open polyspace_project, and create the following directories:
® sources
® includes

® results

3 Copy the file training.cpp from
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Install directory\Examples\Demo_Cpp_Long\sources

to

polyspace_project\sources

where Install directory is the installation directory.
4 Copy the files training.h and zz_utils.h from

Install directory\Examples\Demo_Cpp_Long\sources

to

polyspace_project\includes

Opening the PolySpace Launcher

Use the PolySpace Launcher, a graphical user interface, to create a project
and start a verification.

To open the PolySpace Launcher:

® Double-click the PolySpace Launcher icon on your desktop.

'

PolySpace
Launcher

¢ If you have only the PolySpace Client for C/C++ product installed on your
computer, skip this step. If you have both PolySpace Client for C/C++
and PolySpace Client for Ada products on your system, the PolySpace
Language Selection dialog box will appear.
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PolySspace Language Selection

Select a3 langusge

¥ PolySpace for CIC++

" PolySpace for Ada

0K I Cancel

Select PolySpace for C/C++ and click OK.

The PolySpace Launcher window opens.
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Specify Specify include

source files directories
1
e
File Edit Tools Hel| 1
|Dom|alih X al# 8||» @ *| @ ;
4 I
L ] - H |
- _l _l [y——
| Fiename | | Absolut| Path | I
Whalysis options !
1
—General | H
—TargetiCompilation ! S p ec |fY
—Compliance with standards: ana lySIS
—PalySpace inner settings ! options
—PrecizioniEcaling :
—Muttitasking !
1
1
1
1
1
1
1
1
Include directaries [-ada-inclufle-dir] :
1
1
1
1
1
Files extensions [—extensions—for—spec—files]I :
: ! Control
Results Directory [ -rezults-dir] | . .
I verification
5| '
- 1
1
Send to PolyEpace Server [= &Ex
= i
| Compile : 0% CDF& - 0% | Levell : 0% | Levelz - 0% Monitor
00:00:00 00:00:00 00:00:00 00:00:00 progress

1
|

1

1

' '
% Compile Log |
Stats :
1

Full Log |

View log

The Launcher window has three main sections.
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Use this For...
section...
Upper-left Specifying:

e Source files
® Include directories

¢ Results directory

Upper-right Specifying analysis options

Lower Controlling and monitoring a verification

You can resize or hide any of these sections. You learn more about the
Launcher window later in this tutorial.

Changing the Default Directory

PolySpace software allows you to specify the default directory that appears
in the directory browsers in dialog boxes. If you do not change the default
directory, the default directory is the installation directory. In this tutorial,
you change the default directory to the project directory that you created

in “Preparing the Project Directories” on page 2-4. Changing the default
directory to the project directory makes it easier for you to locate and specify
source files and include directories in dialog boxes.

To change the default directory to the project directory:

1 Select Edit > Preferences.

The Preferences dialog box appears.



Creating a New Project

x

Miscellaneous | Result directory | Default directory | Editors | Generic targets
Tools Menu | Remote Launcher
Menu title Execution command

E

Ok Apply Cancel

2 Select the Default directory tab.
3 Select Always use this specific folder if it is not already selected.

4 Enter or navigate to the project directory that you created earlier. In this
example, the project directory is C: \PolySpace\polyspace project.

The Preferences dialog box should now look like the following.
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x

Tools Menu | Remate Launcher
Miscelaneous I Result directory Default directory | Editars | Generic targets

Default folder for all browsers,

f+ Always use this spedific folder |C:\PolySpace\polyspace_project ! |

i~ Use the current path as a default folder

Ok | Apply | Cancel |

5 Click OK to apply the changes and close the dialog box.

Creating a New Project to Verify a Class in the
Training C++ File

You must have a project, saved with file type .cfg, to run a verification. In
this part of the tutorial, you create a new project to verify training.cpp.

You create a new project by:

® “Opening a New project” on page 2-11

® “Specifying the Source Files, Include Directories, and Results Directory”
on page 2-12

® “Specifying the Analysis Options” on page 2-14
® “Saving the Project” on page 2-17
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Opening a New project

To open a new project for verifying training.cpp:

1 Select File > New Project.

The Choose the language dialog box appears:

x

| ik I Cancell

2 Select C++, then click OK.

The default project name, New_Project, appears in the title bar.

In the Analysis options section, the General options node expands with

default project identification information and options.

search internal name from the selected line: I

21

MName

Value

Internal name

Mew_Project -prog
07/07/2009 date
nolyspace_user -author
----- Project version 1.0 -verif-version
----- Keep all preliminary results files - ~*keep-all-files
----- Continue with the current configuration - -continue-with-existing-host
----- Continue even on an unsupported Linux distribution - -allow-unsupported-inux
[E-Report Generation -
‘- Report template name C:\PalySpace\Polys| ... |-report-template
---Qutput format RTF - -report-output-format

H-Target/Compilation

+|--Compliance with standards

|--Predision fScaling

£
E
[+--PalySpace inner settings
£
£

H--Multitasking

2-11
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Specifying the Source Files, Include Directories, and Results
Directory

To specify the source files, include directories, and results directory for the
verification of training.cpp:

1 Click the green plus sign button in the upper right of the files section of
the Launcher window.

|
The Please select a file dialog box appears.

E Please select a file |

Look in: -3 polyspace_project ﬂ ll lﬁ El

10 includes
100 resuts
150 sources

I(*.cppj and (*.c) files LI

[~ Recurse subdirectories

~Source files [-sources] ~Directories to include [-1]

A B

(6138 Cancel |

2 The project folder polyspace_project should appear in the Look in
drop-down box. If it does not, navigate to that folder.
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Creating a New Project

3 Double-click the sources folder.

4 Select the file training.cpp and then click the green down arrow button
in the Source files section.

H

The path for training.cpp appears in the source files list.

Tip You can also drag files from an open folder directly to the source files
list or the directories to include list.

5 Navigate back to the polyspace_project folder.

Select the directory includes, then click the green down arrow button in
the Directories to include section.

||
The path for the directory appears in the list of directories to include.

6 Navigate to the folder Install directory\Verifier\Include.

7 Select the folder include-1inux, then click the green down arrow button in
the Directories to include section.

Note This tutorial uses a Linux OS target, therefore you must include
the Linux library files. When verifying your code, you should include the
standard headers for your compiler.

8 Click OK to apply the changes and close the dialog box.

9 In Results Directory, specify the directory for the verification results.
Enter the path for the results directory that you created earlier. In this
example, the results directory is C: \polyspace_project\results.
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The files section in the upper left of the Launcher window now looks like this.

cpp_project.cfg _rI ;I

File Mame Absolute Path

Itraining .Cpp C:VPolySpace\polyspace_project\sources

Indude directories [-I]
C:'PolySpace\PolySpaceForCandCPP_R 2009b Werifier indude \indude-inux
C:'\PolySpacepolyspace_projectiincludes

Lt

Results Directory [-results-dir]
C:'\polyspace_projectiresults ) |

Specifying the Analysis Options

The analysis options in the upper-right section of the Launcher window
include identification information and parameters that PolySpace software
uses during the verification process. For more information about analysis
options, see “Options Description” in the PolySpace Products for C++
Reference.

To specify the analysis options for this tutorial:
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1 In the General section, change the Session identifier to
Training_Project.

Note The session identifier cannot contain spaces.

2 Expand the PolySpace inner settings section and select the Generate a
main using a given class check box. This enables the -class-analyzer
option and allows you to specify the class you want to verify. Expand the
Generate a main using a given class section and type in MathUtils as
the class name.

3 Expand the Target/Compilation section. Because you included Linux
header files for this project, you must select a Linux® OS target. This
will provide PolySpace with a set of predefined compilation flags that are
known to be default or implicit compile options for the target OS. Select
Linux from the drop-down menu next to Operating system target for
PolySpace stubs.

4 Keep the default values for all other options.

The analysis options will now look like this.
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Search internal name from the selected line: ,@ | [%?
Mame Value Internal name
Analysiz options
[l-General
----- Seszion identifier Training_Project -prog
----- Date 07/07/2009 -date
----- Author polyspace_user -guthor
----- Project wersion 1.0 -yerif-yersion
----- keep all preliminary results fles - +keep-al-files
----- Continue with the current configuration - -continue-with-existing-host
----- Continue even on an unsupperted Linux distribution - -allow-unsupported-inux
FH-Report Generation r
=- b
----- Target processor type sparc = | .. |target
----- Operating system target for PolySpace stubs Linune - -J5-target
----- Defined Preprocessor Macros v |D
----- Undefined Preprocessor Macros v U
----- Include ... |Hncude
----- Command/script to apply to preprocessed files ... |-post-preprocessing-command
----- Commandscript to apply after the end of the code ... |-post-analysis-command
[#]-Compliance with standards
[=I-PalySpace inner settings
[H--Run a verification unit by unit Il -unit-by-unit
[--Specify a Visual Studio compliant main -
[=--Generate a main for a given dass I
----- Class name Mathltils -class-analyzer
----- Analyze the dass contents only - -class-only
----- Select methods caled by the generated main  |default - -class-analyzer-calls
----- Don't chedk member initialization in the generate [l -no-constructors-init-check
[H--Generate a main for the given functions il
[+-Main generation general options
[H-Stubbing
[#--Assumptions
----- Run verification in 32 or 64-bit mode auto - -machine-architecture
----- Mumber of processes for multiple CPU core systems |4 -MiEx -Orocesses
----- Other options
[#]-Predision/Scaling
[]-Multitasking
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Note You can also select the -class-only option when you want to verify a
single class. When this option is applied, even if you add other classes and
function member definitions, PolySpace will stub them. This accelerates your
verification process and allows you to check robustness issues for a single
class. For the purposes of this tutorial, it is not necessary to select this option
because the class MathUtils does not depend on any other classes.

Saving the Project
To save the project:

1 Select File > Save project. The Save the project as dialog box appears.

x|
Lok it IE,'] polyapace_project ;I I ,.3
I includes
IE] results
IC5) sources
Session idertifier || Ok,
Files of type: Ix_.:fg ll Cancel
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2 Setting Up a Project File

2 In Look in, leave the default directory, polyspace_project.
3 In Session identifier, enter training.

4 In Files of type, leave the default *.cfg. You must have a project file
with type cfg to run a verification.

Note You can also run a verification with a project file of type dsk. Older
versions of PolySpace software created files with type dsk for use with
verifications running on a desktop PC. For more information about the dsk
file type, see “What Is a Project?” on page 2-3.

5 Click OK to save the project and close the dialog box.
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e “About This Tutorial” on page 3-2
® “Opening the Project” on page 3-4

e “Using the Launcher to Start a Verification That Runs on a Server” on
page 3-5

e “Using PolySpace In One Click to Start a Verification That Runs on a
Server” on page 3-15

¢ “Using the Launcher to Start a Verification That Runs on a Client” on
page 3-25
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About This Tutorial

In this section...

“Overview” on page 3-2

“Before You Start” on page 3-3

Overview

Once you have created the project training.cfg as described in “Creating a
New Project” on page 2-3, you can run the verification.

You can run a verification on a server or a client.

Use... For...

Server ® Best performance

Large files (more than 800 lines of code including comments)

Multitasking

Client ® An alternative to the server when the server is busy

Small files with no multitasking

Note Verification on a client takes more time. You might
not be able to use your client computer when a verification is
running on it.

You can start a verification using the Launcher or using PolySpace In One
Click. With either method, the verification can run on a server or a client.
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About This Tutorial

Use... For...

Launcher A basic way to start a verification.

You specify the source files in the project file.
With the project file open, you click a button to
start the verification.

PolySpace In One Click | A convenient way to start the verification of
several files which use the same verification
options.

Once you specify the project file containing the
verification options, you specify the source files
by selecting them from a Microsoft Windows
folder. You start the verification by sending the
selected files to PolySpace software.

In this tutorial, you learn how to run a verification on a server and on a
client, and you learn how to start a verification using the Launcher and
using PolySpace In One Click. You verify the class MathUtils in the file
training.cpp three times using a different method each time. You use:

1 The Launcher to start a verification that runs on a server.
2 PolySpace In One Click to start a verification that runs on a server.

3 The Launcher to start a verification that runs on a client.

Each verification stores the same results in polyspace_project\results.
You review these results in the tutorial Chapter 4, “Reviewing Verification
Results”.

Before You Start

Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Project File”. You use the directories and project file, training.cfg, from
that tutorial to run the verifications.
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Opening the Project

To run a verification, you must have an open project file. For this tutorial, you
use the project file training.cfg that you created in Chapter 2, “Setting Up
a Project File”. Open training.cfg if it is not already open.

To open training.cfg:

1 If the PolySpace Launcher is not already open, open it by double-clicking
the PolySpace Launcher icon.

2 Select File > Open project.

The Please select a file dialog box opens.
3 In Look in, navigate to polyspace_project.
4 Select training.cfg.

5 Click Open to open the file and close the dialog box.
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Using the Launcher to Start a Verification That Runs on
a Server

In this section...

“Starting the Verification” on page 3-5

“Monitoring the Progress of the Verification” on page 3-7
“Downloading Results from the Server to the Client” on page 3-10
“Troubleshooting a Failed Verification” on page 3-12

Starting the Verification
In this part of the tutorial, you run the verification on a server.

To start a verification that runs on a server:

1 Select the Send to PolySpace Server check box next to the Start button
in the middle of the Launcher window.

Send to PolySpace Server [ B Start |

Note If you select Set this option to use the server mode by default
in every new project in the Remote Launcher pane of the preferences,
the Send to PolySpace Server check box is selected by default when you
create a new project.

2 Click Start.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

The verification has three main phases:
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a Checking syntax and semantics (the compile phase). Because PolySpace
software 1s independent of any particular C++ compiler, it ensures that
your code is portable, maintainable, and complies with ANSI® standards.

b Generating a main if it does not find a main and the Generate a Main
option is selected. For more information about generating a main, see
“Generate a Main Using a Given Class” in the PolySpace Products for
C++ Reference.

¢ Analyzing the code for run-time errors and generating color-coded
diagnostics.

The compile phase of the verification runs on the client. When the compile

phase finishes:

® A message dialog box tells you that the verification is completed. This
message means that the part of the verification that takes place on the
client is complete. The rest of the verification runs on the server.

* A message in the log area tells you that the verification was transferred
to the server and gives you the identification number (Analysis ID) for
the verification. For this verification, the identification number is 2.

Send to PolySpace Server [v ¥ Start |

Compile : 1009%% | Mormalization : 0% C++Link : 0% Intermediate : 0% | Leveld : 0% |

00:00:05 00:00:00 00:00:00 00:00:00 00:00:00
% Compile Search: 44 I (43
_@ stats Status Description File Line | Col

@ Full Log 1 Polyspace Launcher for CPP verification start at Jul 7, 2009...
——| [ [The analysis has been queued with ID=1

3 When you see the message Verification process completed, click OK
to close the message dialog box.

4 Stop the Launcher by clicking File > Quit.
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Monitoring the Progress of the Verification

You monitor the progress of the verification using the PolySpace Queue
Manager (also called the Spooler).

To monitor the verification of Example Project:

1 Double-click the PolySpace Spooler icon:

The PolySpace Queue Manager Interface opens.

i PolySpace Queue Manager Interface

Cperations  Help

D | Author Application Fezultz directory CPU| Status | Date |Lan
pour_name  Training _Project C:hpolyspace_projecthresulls anse running 003,

Tip You can also open the Polyspace Queue Manager Interface by clicking

the PolySpace Queue Manager icon E in the PolySpace Launcher toolbar.

2 Point anywhere in the row for ID 1.

3 Right-click to open the context menu for this verification.
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Follow Progress. ..

Wigw Log File. ..

Download Results., ..

Download Resulks And Remove From Queue. ..

Mowve Down In Quele

Skop...
Stop &nd Download Results. ..
Stop &nd Remove From Quele. .,

Remove From Queue. ..

4 Select View log file.

A window opens displaying the last one-hundred lines of the verification.

" Polyepace', PolySpace_Common' Remotelauncher’,whi

GUI files generation complete.

Generating remote file
Done

Certain <red? errors have been detected in the analysed code dug
se .

Analysis continuing because the option —continue—with—-red—-error

a0 o~ J0f -3 ~Jof-J0f ~Jaf~Jof- 0 ~aE-JoE 30 3o -JoF 3o -3eE-JoF -Juf e -Juf -Jnf~ef - -Jnf—Jef - Juf—ef~Jof - Juf—Jof-Jof - Juf—Jef-Jof ~Juf~Jef-Jof ~3uf~Jef-Jof ~3eE-JoE-Jof~JeE-Jof I -3eE-Jof-Juf-3ef-Juf-Juf-ef-Juf-f-
CaEaEad

#3#% Leyel 4 Software Safety Analysis done
EaXaZad

- oE-JmE 30 e e J0f 3o -eE-JmE-Jof -eE -3eE-JeE-JeE-oE-JnE-Jo e 3o -Jef-3uE e -JnE-Jmf 30 e -JmE-3uE e - JeE-JE 30 3o - oE-JnE 30 eEJnE-Jef 3o -eE-JmE 3o e 3eE-Je 3o e -JnE-Jef e -IeE-Jmf-3uf e -JeE-Juf-eE
Ending at: Apr 11, 20008 12:29:8

Uzer time for pass4: 35.8real, 35.8u + Bs

Uzer time for poluyspace—-c: 17Y6.5real,. 176.5u + Bs

CaZaZad

#*x% End of PolySpace Uerifier analysis
CaXaZad

Press enter to close the window ...

5 Press Enter to close the window.
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6 Select Follow Progress from the context menu.

A Launcher window labeled PolySpace follow remote analysis
progress for CPP appears.

H PolySpace follow remote code verification progress 1Ol =l
File Edit Help
Send ta PolyShace Server v B Start

e G+ Lirik : 1

- EER -
00:00:04 00:00:55

00:00:56 00:01:C T
4] 3
% Compile Search; 44 I (313
i
é defr uwber of NTL : 0 ;I
Estets  praver o wTC : 0
@FullLog umber of UNR : 4

: | Ittt
00:00: 25 00:00:1

Certain (Fed) errors sumnmary:
- certain 0BAI, array index within bounds: [0..3], File main.cpp, line 61, columh 9

GUI files generation complete.

Generating results in a spreadsheet format in C:WPolydpaceWPoly3pace RLDatas‘analvsiszhPolyipace-Doc

Generation complete

Eaai oo ok ok ok o ok ko b ko aha aab o ao  ahaol  oaol  ok  o
kg

#+*% Zoftware Safety Integration Analysis Lewel 4 done

[l
. i

“erification completed

You can monitor the progress of the verification by watching the progress
bar and viewing the logs at the bottom of the window. The word
processing appears under the current phase. The progress bar highlights
each completed phase and displays the amount of time for that phase.

The logs report additional information about the progress of the
verification. The information appears in the log display area at the bottom
of the window. The full log displays by default. It display messages, errors,
and statistics for all phases of the verification. You can search the full log
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by entering a search term in the Search in the log box and clicking the
left arrows to search backward or the right arrows to search forward.

7 Click the Compile Log button to display compile phase messages and
errors. You can search the log by entering search terms in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

8 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.

9 Click the refresh button
G5 |
to update the stats log display as the verification progresses.
10 Select File > Quit to close the progress window.
11 Wait for the verification to complete.

When the verification completes, the status in the PolySpace Queue
Manager Interface changes from running to completed.

i PolySpace Queue Manager Interface
Cperations  Help
D | Author Application Feszults directany CPU|[ Statuz | Date | L

pour_name  Training_Project C:\polpzpace_projecthresults ahze xompletec 008, °

Downloading Results from the Server to the Client

At the end of the verification, the results are on the server. To download the
results to your client:

1 In the PolySpace Queue Manager Interface, select Download Results
from the context menu for the verification.

The Browse For Folder dialog box appears with the
polyspace_project\results folder selected.
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Directory where ko store the results

) Perl -
=) PalySpace
=l 15 polyspace_project

I includes J

I3 resulks
I sources

I3 PalvSpace_Results -
= I _*|_I

Folder: I results

Make Mew Falder | (0] 4 I Cancel |

2 Click OK to close the dialog box.

A dialog box appears telling you that the download is complete and asking
if you want to open the PolySpace Viewer.

Queston X

Downlaad completed, Da you wank ko open PalvSpace Yiewer 7

Yes Mo |

3 Click No.

4 Select Remove From Queue from the context menu.

A dialog box appears asking you to confirm that you want to remove the
verification from the queue.
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3-12

Question =

Do wou really want to removwe the analvsis 1 From the queue ?

Yes Mo |

5 Click Yes.

Note

¢ To download the results and remove the verification from the queue,
select Download Results And Remove From Queue from the context
menu.

¢ If you download results before the verification completes, you get partial
results and the verification continues.

6 Select Operations > Exit to close the PolySpace Queue Manager
Interface.

Once the results are on your client, you can review them using the PolySpace
Viewer. You review the results from the verification in Chapter 4, “Reviewing
Verification Results”.

Troubleshooting a Failed Verification

When you see a message that the verification failed, it indicates that
PolySpace software could not perform the verification. The following sections
present some possible reasons for a failed verification.

Hardware Does Not Meet Requirements

The verification fails if your computer does not have the minimal hardware
requirements. For information about the hardware requirements, see

www.mathworks.com/products/polyspaceclientc/requirements.html.


http://www.mathworks.com/products/polyspaceclientc/requirements.html
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To determine if this is the cause of the failed verification, search the log for
the message:

Errors found when verifying host configuration
You can:

e Upgrade your computer to meet the minimal requirements.

¢ Select the Continue with current configuration option in the General
section of the Analysis options and run the verification again.

You Did Not Specify the Location of Included Files

If you see a message in the log, such as the following, either the files are
missing or you did not specify the location of included files.

include.h: No such file or directory

For information on how to specify the location of include files, see “Creating a
New Project to Verify a Class in the Training C++ File” on page 2-10.

PolySpace Software Cannot Find the Server

If you see the following message in the log, PolySpace software cannot find
the server.

Error: Unknown host

PolySpace software uses information in the preferences to locate the server.
To find the server information in the preferences:

1 Select Edit > Preferences.

2 Select the Remote Launcher tab.
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x

Miscellaneous | Result directory | Default directory | Editors | Generic taroets
Tools Menu Remote Launcher

—Remote configuration

[+ Set this option to use the server mode by defaultin every new project

Mote: this option is mandatory when the project contains multitasking options.

The multitasking options will be ignored otherwise.

i+ Automatically detect the remote server

i~ Use the following server and port : 12427

The server name Tocalhost™ can be used if the server is the local machine.

Cancel

Ok |

By default, PolySpace software automatically finds the server. You can

specify the server by selecting Use the following server and port and
providing the server name and port. For information about setting up a
server, see the PolySpace Installation Guide.
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Using PolySpace In One Click to Start a Verification That
Runs on a Server

In this section...

“Overview of PolySpace In One Click” on page 3-15
“Setting the Active Project” on page 3-15

“Sending the Files to PolySpace Software” on page 3-17

Overview of PolySpace In One Click

In a Microsoft Windows environment, PolySpace software provides a
convenient way to streamline your work when you want to verify several
files using the same set of options. Once you have set up a project file that
has the options you want, you designate that project as the active project,
and then send the source files to PolySpace software for verification. You do
not have to update the project with source file information. This process is
called PolySpace In One Click.

In this part of the tutorial, using PolySpace In One Click, you learn how to:

1 Set the active project.

2 Send files to PolySpace software for verification.

Setting the Active Project

The active project is the project that PolySpace In One Click uses to verify the
files that you select. Once you have set an active project, it remains active
until you change the active project. PolySpace software uses the analysis
options from the project; it does not use the source files or results directory
from the project.

To set the active project:

1 Right-click the PolySpace In One Click icon in the taskbar area of your
Windows desktop:
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The context menu appears.

Set active project k

Open ackive project - Training_Project

Viewer

Launcher

7 & T

Spoaler
Help »

Exit

2 Select Set active project > Browse from the menu.

The Please set an active project dialog box appears:
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Please set an active project. d |

Laak i I&} polvzpace_project j 4= fji v

includes
resulks
S0UFCES

E?_", training.cfg

Open

Cancel

File narne: || j
=

il

Filez of type: IF'cul_l,ISpace configuration files

3 In Look in, navigate to polyspace_project.
4 Select training.cfg.

5 Click Open to apply the changes and close the dialog box.

Sending the Files to PolySpace Software
You can send several files to PolySpace software for verification. For this
tutorial, you send one file, training.cpp.

To send training.cpp to PolySpace software for verification:

1 Navigate to the directory polyspace _project\sources.
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2 Right-click the file training.cpp.

The context menu appears.

Mame =+ I

Open

Edit

Cpen with WordPad
ca Scan for viruses. ..

& 17Arc 3
Open With k
) WinZip 3
Send To »
Cut
Copy

Create Shortcut
Delete
Rename

Properties

3 Select Send To > PolySpace.
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Marme | Size | Type
m SKE CPP File

Open
Edit
Cpen with WordPad

ca Scan for wiruses, .,
Open iith 3

&5 WinZip 2
Send To [£] Compressed (zipped) Folder
Cuk [@ Desktop (create shortout)
Copy [ Fax Destination wvia RightFa
Create Shorkout (% Macromedia FresHand My
Delete

| Mail Recipient
_D My Dacurments
Propetties PolySpace

Renarme

L 314 Floppy (A1)

The PolySpace basic settings dialog box appears.
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PolySpace basic settings [ C++ ] - |EI|1|
Settings
Precision IOZ j
Passes Pass2 (Software Safety Analysis level 2) =l
Parameters
Results directory |C:\PoIySpac:e\poIyspace_project\results |
Function called before main | |
Main generator write variables IUnin'rt j
Class analysis File analysis | Main analysis
Class I j
Class analyzer calls IUnused j
[¢] Class only

Scope

C\PolySpace’\polyspace _project ‘sources'training cpp

[1]+

¥l Send to PolySpace Server D) Startl @Canoel |

4 Make sure that Results directory is polyspace _project\results.

5 You will see that there are three different tabs in the Parameters section
to assist you in setting up the type of verification you want to run. In this
tutorial, you are verifying a single class, so you want to use the Class
analysis tab to set up the analysis parameters. Under the Class analysis
tab, type MathUtils in the box labeled Class. You will see that the Class
only checkbox is selected by default. This activates the -class-only option
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in PolySpace. For the purposes of this tutorial, it does not matter whether
or not this option is applied because the class MathUtils does not depend
on any other classes.

6 Select the Send to PolySpace Server option if it is not already selected.

7 Leave the default values for the other parameters.

The PolySpace basic settings window should now look like this.
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E PolySpace basic settings [ C++ ] - |EI|1|
Settings
Precision IOZ
Passes IPassZ {Software Safety Analysis level 2)
Parameters
Results directory |C:\POIy5pace_Result5 |
Function called before main | |
Main generator write variables IUnin'rt j
Class analysis File analysis | Main analysis
Class IMathUtiIs j
Class analyzer calls IUnused j
[¢] Class only
Scope

C\PolySpace’polyspace_project ‘sources'training cpp

[1]+

[¥] Send to PolySpace Server D) S1a't| @Can:ell

Click Start.

The verification log appears.

3-22



Using PolySpace® In One Click to Start a Verification That Runs on a Server

E C:\polyspace_project\results =10l x|
E= & e -

Mumber of lines Can: :I
Mumber af lines without comments © 106
Murnber of lines with libraries : GE7E

ffffffffffffffffffffffffffffffffffffffffffffffffffffffffff

ffffffffffffffffffffffffffffffffffffffffffffffffffffffffff

Ending at: Jul 22, 2008 14:6:17

Generating remote file

Oone

Uger tirme for polyspace-cpp: 1.9real, 1.90 + 0=

333

**End of PolySpace Verifier analysis
B3

Ldding the analysis to the quene .
Tranzfering the archive to the server ...

Transfer completed.
Analysiz Do 1
The analysiz has heen gueued. You may follow itz progress using the spooler.

-
4| | b

|The analyziz haz been succeszfully done

The compile phase of the verification runs on the client. When the compile
phase completes:
* You see the message:

End of PolySpace Verifier analysis

* A message in the log area tells you that the verification was transferred to
the server and gives you the identification number (Analysis ID) for the
verification. For this verification, the identification number is 1.

e Monitor the verification using the Spooler. For information on using the
Spooler to monitor a verification on a server, see “Monitoring the Progress
of the Verification” on page 3-7.
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e When the verification completes, download the results to
polyspace _project\results. For information on downloading results

from a server to a client, see “Downloading Results from the Server to the
Client” on page 3-10

You review the results in Chapter 4, “Reviewing Verification Results”.
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Using the Launcher to Start a Verification That Runs on a
Client

In this section...

“Starting the Verification” on page 3-25
“Monitoring the Progress of the Verification” on page 3-26
“Completing the Verification and Stopping the Launcher” on page 3-27

“Stopping the Verification Before It Completes” on page 3-28

Starting the Verification

For the best performance, run verifications on a server. If the server is busy
or you want to verify a small file, you can run a verification on a client.

Note Because a verification on a client can process only a limited number
of variable assignments and function calls, the source code should have no
more than 800 lines of code.

To start a verification that runs on a client:

1 Open the Launcher if it is not already open.
2 Open the project file training.cfg if it is not already open.

For information about opening a project file, see “Opening the Project”
on page 3-4.

3 Make sure that the Send to PolySpace Server check box is clear.

4 If you see a warning that multitasking is not available when you run
a verification on the client, click OK to continue and close the message

box. This warning only appears when you clear the Send to PolySpace
Server check box.

5 Click the Start button.
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P Start |

6 If you see a caution that PolySpace software will remove existing results
from the results directory, click Yes to continue and close the message
dialog box.

The progress bar and logs area of the Launcher window become active.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

Monitoring the Progress of the Verification

You can monitor the progress of the verification by watching the progress bar
and viewing the logs at the bottom of the Launcher window.

Cotmpile © 100% IErmalizatiDn: 15% | C++ Link ; 0% | Intermediste | 0% | Lewvell : 0% |
0o 0o; 02 00: 00: 08 0 Q; 0y 00: 00: 00 0 Q; 0y
C':'mpile Search 44 | (13

Stats | status| Description | File | une | ca

@ Full Log 1 |P'|:|Iy5pa|:e Launcher for CPP ver...| | |

The progress bar highlights the current phase in blue and displays the
amount of time and completion percentage for that phase.

The logs report additional information about the progress of the verification.
To view a log, click the button for that log. The information appears in the
log display area at the bottom of the Launcher window. Follow the next steps
to view the logs:

1 The compile log displays by default.
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This log displays compile phase messages and errors. You can search the
log by entering search terms in the Search in the log box and clicking the
left arrows to search backward or the right arrows to search forward.

2 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.

3 Click the refresh button

_® |

to update the display as the verification progresses.

4 Click the Full Log button to display messages, errors, and statistics for all
phases of the verification.

You can search the full log by entering a search term in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

Completing the Verification and Stopping the
Launcher

When the verification completes, a message dialog box appears telling you
that the verification is complete and asking if you want to open the Viewer.
For this tutorial, do not open the Viewer at this point.

E x|

@ ‘erification process completed,
Do you wank ko launch PolySpace Viewer #

To indicate that you do not want to open the Viewer:
¢ (Click Cancel.

You can also open the Viewer from the Launcher toolbar, but for this tutorial,
you do not do this. For this tutorial, close the Launcher.
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3-28

To close the Launcher:
® Select File > Quit.

In the tutorial Chapter 4, “Reviewing Verification Results”, you open the
Viewer and review the verification results.

Stopping the Verification Before It Completes

You can stop the verification before it completes. If you stop the verification,
results will be incomplete, and if you start another verification, the
verification starts over from the beginning.

To stop a verification:

1 Click the Stop Execution button.

@ Stop Execution |

A warning dialog box appears.

waming x|

@ Do wou really want to stop the current execution ?

o |

2 Click Yes.

The verification stops and the message Verification process stopped
appears.

3 Click OK to close the Message dialog box.
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Note Closing the Launcher window does not stop the verification. To resume
display of the verification progress, open the Launcher window and open the
project that you were verifying when you closed the Launcher window.
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Reviewing Verification
Results

e “About This Tutorial” on page 4-2

® “Opening the Viewer and the Verification Results” on page 4-3
¢ “Exploring the Viewer Window” on page 4-5

¢ “Reviewing Results in Expert Mode” on page 4-10

* “Reviewing Results in Assistant Mode” on page 4-28

® “Generating Reports of Verification Results” on page 4-35
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About This Tutorial

In this section...

“Overview” on page 4-2

“Before You Start” on page 4-2

Overview

In the previous tutorial, Chapter 3, “Running a Verification” , you completed a
verification of the class MathUtils in the file training.cpp. In this tutorial,
you explore the verification results.

PolySpace Client for C/C++ provides a graphical user interface, called the
Viewer, that you use to review results. In this tutorial, you learn:

1 How to use the Viewer, including how to:

® Open the Viewer and open verification results.

Select the Viewer mode.

Explore results in expert mode.

Explore results in assistant mode.

® Generate reports.

2 How to interpret the color-coding that PolySpace software uses to identify
the severity of an error.

3 How to find the location of an error in the source code.

Before You Start

Before starting this tutorial, complete the tutorial Chapter 3, “Running a
Verification”. In this tutorial, you use the verification results stored in this
file:

polyspace_project\results\RTE_px_02_Training_Project_ LAST_RESULTS.

rte.



Opening the Viewer and the Verification Results

Opening the Viewer and the Verification Results

In this section...

“Opening the Viewer” on page 4-3
“Selecting the Viewer Mode” on page 4-3

“Opening the Results” on page 4-4

Opening the Viewer

You use the Viewer to review verification results. Open the Viewer if it is
not already open.

To open the Viewer:

® Double-click the PolySpace Viewer icon:

Note You can also open the Viewer from the Launcher by clicking the Viewer
icon in the Launcher toolbar with or without an open project.

Selecting the Viewer Mode

You can review verification results in expert mode or assistant mode:

® In expert mode, you decide how you review the results.

¢ In assistant mode, PolySpace software guides you through the results.

You switch from one mode to the other by clicking a button in the Viewer
toolbar. For this part of the tutorial, the Viewer should be in expert mode. If
the Viewer is in expert mode, the switch mode button in the toolbar displays
Assistant.
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G Assistant

If the Viewer is not in expert mode, click the mode button to switch to expert
mode.

{J§_'.‘ Expert |

You learn more about expert and assistant modes later in this tutorial.

Opening the Results

To open the verification results:

1 Select File > Open.

2 In the Please select a file dialog box, navigate
to polyspace_project\results and select the file
RTE_px_02_Training_Project_LAST_RESULTS.rte.

3 Click the Open button.

The results appear in the Viewer window.

Note The file RTE_px_02_Training_ Project LAST_RESULTS.rte represents
the verification with the highest level of precision. The lower level results
files that you see in the polyspace_project\results directory represent
lower precision verifications.




Exploring the Viewer Window

Exploring the Viewer Window

In this section...

“Overview” on page 4-5

“Reviewing the Procedural Entities View” on page 4-7

Overview
The PolySpace Viewer window looks like this.
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Coding review progress view Selected check view

Fil= Edt WWindows Help

tipace Viewer - C:\polyspace_project\results\RTE_px_02_Training_Project_LAST ||

g [ 3]

| &|m

s ﬂ|°ﬁ B [ e i'J"-S"“ﬁfJ‘gﬂﬁ

J‘ x| 7 » THE A4 ||osn| o I‘w" AL sH WNT [ 0P oPP [ COR POW

JIUseldef Vl (;%Assistantl
FRY Ioi‘{'g,lmp oop  ExC TR pseT  wTC INTL UNR.

Coding review progress Court | Pr... | 4 Mo check currently selected
o check selected hia hia
b reviesved ok to reviewy (nia) iz iz - @I
|| Software relisbility indicatar hia hia

Procedural entities | i |x| + ‘/l Line | :

B rrsiing_

#—exception.stdh

+—new.stdh
AE—training b 2

+—_ polyspace_ stdstubs .

1
1
1
—training opp 1 4| 1
1
1
1

[—_polyspaca_stdstubscpp.cpp

: jer 1o 44 1
H
¥ polyspace_main.cpp 1 Training_Project

@—Jolyspace_main._

1| [ Coll e vie o

CE——— EER
4 | B

Training_Project Source file: __polyspace | stdstubscpp.cpp

_| polyspace_ stdstulscpp.cpp Line: 1

Procedural Variables
entities view view

Source code Call tree
view view

The appearance of the Viewer toolbar depends on the Viewer mode. Because
the Viewer is in expert mode, the expert mode toolbar is displayed.

W B e i 'J"Q'"'S““J"g'

CALLS

L

I ! I WIY  SCAL : ] ! : : I HIM I ! : . FLOAT,
OBAI - Z0W o (BLS, . RUFL 0 SHF - WNT | IDP . PP - GOR - FRY | oo o WIP - 0OF - EXC - CaiE

Jlm- G Assistant |




Exploring the Viewer Window

In both expert mode and assistant mode, the Viewer window has six sections
below the toolbar. Each section provides a different view of the results. The

following table describes these views.

This view...

Displays...

Procedural entities view (lower left)

List of the diagnostics (checks) for
each file and function in the project

Source code view (lower right)

Source code for a selected check in
the procedural entities view

Coding review progress view (upper
left)

Statistics about the review progress
for checks with the same type and
category as the selected check

Selected check view (upper right)

Details about the selected check

Variables view

Information about the global
variables declared in the source code

Note The file that you use in
this tutorial does not have global
variables.

Call tree view

Tree structure of function calls

You can resize or hide any of these sections. You learn more about the Viewer

window later in this tutorial.

Reviewing the Procedural Entities View

The procedural entities view, in the lower-left part of the Viewer window,
displays a table with information about the diagnostics for each file in the
project. The procedural entities view is also called the RTE (Run-Time
Error) view. When you first open the results file from the verification of
training.cpp, the procedural entities view looks like this.
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Procedural entities X + |Line|...| &

| I
[-iﬂ---_:: WSPSCE_MEin. Cpp 1)1 100 | pohyspace_main.cpp
Eiﬂ--ax:sapti:nr.;t-:l‘ 0 [exception.stdh
Eh...ra_f,.;_at.:r 0 [new.stdh
|Ei§|...|-; ning.cpp 45 i B2 [training.cpp
EE|- nineg. h 2 L 100 [training. h
Eiﬂ---_pah.rapa:e_at-: stubs.c i 0 |_polyspace__stdstub
|E£---_pahr5pa:>a_5t-: stubscpp.cpp 1 0 | _polyspace__stdstub

The file training.cpp is red because its contains a run-time error. PolySpace
software assigns a file the color of the most severe error found in that file.
The first column of the table is the procedural entity (the file or function).
The following table describes some of the other columns in the procedural

entities view.

Column
Heading

Indicates

[1]

Number of red checks (operations where an error always
occurs)

Number of gray checks (unreachable code)

Number of orange checks (warnings for operations where
an error might occur)

Number of green checks (operations where an error never
occurs)

o | | | 1 |

Selectivity of the verification (percentage of checks that are
not orange)
This is an indication of the level of proof.

Tip If you see three dots in place of a heading, J, resize the column until you
see the heading. Resize the procedural entities view to see additional columns.
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Note You can select which columns appear in the procedural entities view
by editing the preferences. To learn how to add a Reviewed column, see
“Making the Reviewed Column Visible” on page 4-14.

What you select in the procedural entities view determines what displays in
the other views. In the following examples, you learn how to use the views
and how they interact.
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Reviewing Results in Expert Mode

In this section...

“What Is Expert Mode?” on page 4-10

“Switching to Expert Mode” on page 4-10

“Reviewing Checks in Expert Mode” on page 4-10
“Reviewing Additional Examples of Checks” on page 4-17
“Filtering the Types of Checks That You See” on page 4-21

What Is Expert Mode?

In expert mode, you can see all checks from the verification in the PolySpace
Viewer. You decide which checks to review and in what order to review them.

Switching to Expert Mode

If the Viewer is in expert mode, the switch mode button displays Assistant.
If the Viewer is in assistant mode, the switch mode button displays Expert.
To switch from assistant to expert mode:

e (Click the Viewer mode button:
~'§.'.‘ Expert

The Viewer window toolbar displays buttons and menus specific to expert
mode.

Reviewing Checks in Expert Mode

In this part of the tutorial, you learn how to use the Viewer window views to
examine checks from a verification. This part of the tutorial covers:

e “Selecting a Check to Review” on page 4-11
¢ “Displaying the Calling Sequence” on page 4-12

e “Tracking Review Progress” on page 4-13
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e “Making the Reviewed Column Visible” on page 4-14

Selecting a Check to Review

In the procedural entities view, training.cpp is red, indicating that this file
has at least one red check. To review a red check in training.cpp:

1 In the procedural entities section of the window, expand training.cpp.
2 Expand the red procedure MathUtils::Pointer_Arithmetic().

A color-coded list of the checks performed on
MathUtils::Pointer_Arithmetic() appears:

[F-MathUHils:: Pointer_Amthmetics

4 -
m G
(] n

Each item in the list of checks has an acronym that identifies the type

of check and a number. For example, in IDP.11, IDP stands for Illegal
Dereferenced Pointer. For more information about different types of checks,
see “Check Descriptions” in the PolySpace Products for C++ Reference.

3 Click on the red IDP.11.

The source code view displays the section of source code where this error
occurs.
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4-12

=&l x|

65 int tab[l00];

(13 int i, *p = tab:

67

65 for(i = 0; 1 <« 100; i+, pH+]
69 Fp o= 0;:

70

71 if (u.randow int() == 0]

T2 p o= 32 A4 Dut of bounds
73

74 i = u.random_int(];

75 if (w.random inti)) ip-i) = 10:
76

77 if (01 && i<=100)

75 i

| 4]

4 At line 72 of the code, click on the red code.

An error message box appears indicating that when the pointer p is
dereferenced, it is outside of its bounds. At line 66, p points to the start of
tab which has 100 elements. The for loop starting at line 68 initializes
the elements of tab to 0. This for loop leaves p pointing to the location
after the last element of tab.

Displaying the Calling Sequence
You can display the calling sequence that leads to the code associated

with a check. To see the calling sequence for the red IDP.11 check in
MathUtils::Pointer_Arithmetic():

1 Expand MathUtils::Pointer_ Arithmetic().

2 Click the red IDP.11.

E
3 Click the call graph button in the toolbar. “%"
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Training_Pro]'ect - Call graph for check training.cpp MathUtilszPointer. - | Ellil

Cl

Training_Project - Call graph for chedk training.cpp MathUtils::Painter_Arithmetic().IDP. 11 I

A window displays the call graph.

116% - J i+

O

main

_polyspace_main.cpp training.cpp training.cpp

O Ly

MathUtils: : Pointer_Arithmetic() IDP.11

The code associated with IDP.11 is in MathUtils: :Pointer_ Arithmetic.
The generated main function calls MathUtils::Pointer_ Arithmetic.

Tracking Review Progress

You can keep track of the checks that you have reviewed by marking
them. To mark that you have reviewed the red IDP.11 check in
MathUtils::Pointer_Arithmetic():

1 Expand MathUtils::Pointer_Arithmetic().
2 Click the red IDP.11.

A table with statistics about the review progress for that category and
severity of error appear in the upper-left part of the window.

I Coding review progress Count |Progress
Inum IDP reviewed [ num IDP to review (Red) [0f1 i
Inum reviewed / num to review (Red) 0/1 0
ISu:uft'.r'.'arE reliability indicator 33/102 a6
I
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4-14

The Count column displays a ratio and the Progress column displays the
equivalent percentage. The first row displays the ratio of reviewed checks
to the total number of checks that have the same color and category as the
current check. In this example, it displays the ratio of reviewed red IDP
checks to total red IDP errors in the project.

The second row displays the ratio of reviewed checks to total checks that
have the same color as the current check. In this example, this is the ratio
of red errors reviewed to total red errors in the project. The third row
displays the ratio of the number of green checks to the total number of
checks, providing an indicator of the reliability of the software.

Information about the current check (the red IDP.11) appears in the
upper-right part of the Viewer window.

training.cpp F Mathltils::Painter_Arithimetic) £ line 72 7 column 4

+ po= &r fF 0ut of bounds
r =

IEerr  pointer iz outzide its bounds

3 Select the check box to indicate that you have reviewed this check. You can

enter a comment in the comment box.

The Coding review progress part of the window updates the ratios of
errors reviewed to total errors.

I Coding review progress Count |Progress
Inum IDP reviewed [ num IDP to review (Red) [1f1 100
Inum reviewed / num to review (Red) 11 100
ISu:uf't'.-x'arE reliability indicator 358/102 a6
I

Making the Reviewed Column Visible

You can change the PolySpace Viewer preferences so that the procedural
entities part of the window displays a Reviewed column.
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1 Select Edit > Preferences.

2 Select the Table options tab.

3 Under Display columns in RTE view, select the Reviewed check box.
Now the Table options tab looks like this.

HPrEferences PolySpace Yiewer

Tools Wenu  Takle options | Toolbars Dptiu:unsl hizcellansous

~Dizplay columns in RTE wiew ~Display columns Yariable
IV Gray V¥ b read
v Qrange V¥ Mi werite
¥ Green v Wiiting Tasks
V¥ Line v Reading Tasks
v Calurnt ¥ Protection
¥ Tatal Selectivity | Uzage
[V Details v Line
V¥ Column
[ comnerts IV File
v Detailed Type
¥ “alues

4 Click OK to apply the preference and close the dialog box.

A column of check boxes appears in the Procedural entities view.
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The check box for IDP.11 in MathUtils::Pointer_Arithmetic() is selected
because you selected the check box for this diagnostic in the current check
view (upper- right part of window).

Procedural entities Line|...| & Details ...

ﬁ Training_Project 81 -
-_pohyspace_main. cpp 100 | polyspace main.cpp| [T
[H]--exception. stdh 0 fexxception.stdh |_
[H]--mezswr. stdh 0 |new.stdh I_
(- training.cop B2 [training.cpp |-
- 12 |16 | 63 (training.cpp |_
B3--MathUiils: :Man_Infinite_Loop 39 | 15 | 100 ftraining. cpp |_
E3-MathlUtils; ;Pointer_Arithmetic]) &1 |16 | 88 (training.cpp r

..... WF EXC &1 function does not th...| [

..... W OVFL.4 68 |22 zcalar varisble dos | [

..... ~ UMNFL.E 88 |23 scalar varisble doss. .. |_

..... o EXNCE ™™ |17 call to random_int d.... |_

..... +F MNT.10 71|17 this-pointer of rande...| [

..... -i - T2 | 4 Error ; pointer is out... |7

..... W EXC.13 T4 |18 call to random_int d... |-

..... o NNT. 14 T4 | 18 this-pointer of rando... |_

..... o EXC.15 TH |18 call to random_int d... I_

Tip If you do not see this column, resize Procedural entities so that you see

the column. Resize the column to see the Reviewed label.

Note Selecting a check box in the Reviewed column automatically:

¢ Selects the check box for that check in the current check view (upper-right
part of the window).

¢ Updates the counts in the coding review progress view (upper-left part

of the window).
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Reviewing Additional Examples of Checks

In this part of the tutorial, you learn about other types and categories of
errors by reviewing the following examples in training.cpp:

¢ “Example: Unreachable Code” on page 4-17
e “Example: A Function with No Errors” on page 4-18

e “Example: Division by Zero” on page 4-19

Example: Unreachable Code

Unreachable code is code that never executes. PolySpace software displays
unreachable code in gray. In the following steps, you will look at an example
of unreachable code.

1 In Procedural Entities, click on Square: :Unreachable Code().

The source code for this function displays in the source code view.
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le0 S* Here we demonstrate PolySpace Verifier's ability to

lal identify unreachahle sections of code due to the
162 walue constraints placed on the wariables.
163 Ly

164 wold Soquare: iUnreachable Codel)

a5 {

laa Ttils ua:

1a7 int ¥ = w.random_inti];

1aS int ¥ = w.random_inti];

1g9

170 if (x > ¥)

171 i

172 ¥ =X - ¥

173 if (x < 0}

174 x=x 4+ 1;

175 1

176

177 X =¥;

175 i

il

1ol

=l

2 Examine the source code.

At line 174, the code x = x +1 is never reached because the condition x
< 0 is always false.

Note that in the Procedural Entities view all public and protected member
functions for the classes RTE and Square are marked as unreachable code.
This is because the analysis results are from the single class verification of
MathUtils which does not depend on any other classes.

Example: A Function with No Errors

In the following example, PolySpace software determines, in code with a large
number of iterations, that a loop terminates and a variable does not overflow:




Reviewing Results in Expert Mode

1 In Procedural entities, click on the green
MathUtils::Non_Infinite Loop() function.

The source code for this function is displayed in the source code view.

—Ioix]
34 Correct operation is demomonstrated bhecause: il
35 l) = = x + 2 iz shown Lo never generate an overflow

36 2] the loop is not infinite

37 */ —
38

39 int MathUtils::Non Infinite Loop ()

40 {

41 const int big = 1073741821 ; /F Z¥%30-3

42 int x=0, ¥=0;

43

44 while (1 == 1)

45 {

45 if (v > big) hreak:

47 X o=x+ Z;

48 ¥T=x/2

49 '

50

il o=k 100;

52 return ¥:

53 ! il
K1l b

2 Examine the source code. The variable x never overflows because the while

loop at line 44 terminates before x can overflow.

Example: Division by Zero

In the following example, PolySpace software detects a potential division

by zero:

1 In Procedural entities, expand MathUtils: :Recursion().
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The source code for this function is displayed in the source code view.

R
A

a3 If the initial walue passed to Becursion()l is negatiwve, then

94 the recursive loop will at some point attempt a division

95 by =zero.

95 7

a7

98 vold Mathlitils: :Recursion 2(int* depth)

99 {

1na Recurzion (depth):

101 3

102

1403 J* if depth<0, recursion will lead to division by =zero */ =

104 vold Mathltils::Recursion (int* depth)

105 {

106 float adwance;

107

103 *depth = “depth 1:

109 adwvance = 1.0/(float) (*depth); // potential diwision by zero

110

111 if (#depth < 50]

112 1

113 Fecursion Z(depth] ;

114 i

115 3 -

i 5

2 Examine the MathUtils: :Recursion() function.

When Recursion() is called with depth less than zero, the code at line
109 will result in division by zero. The orange color indicates that this is a
potential error (depending on the value of depth).
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Filtering the Types of Checks That You See

You can filter the checks that you see in the Viewer so that you can focus

on certain types of checks. PolySpace software provides three predefined
composite filters, a custom composite filter, and several individual filters. You
learn about filters in the following sections:

¢ “Using Composite Filters” on page 4-21

¢ “Using the Custom Filter” on page 4-22
¢ “Using Individual Filters” on page 4-25

Using Composite Filters
Composite filters combine individual filters, allowing you to display or hide
groups of checks.

Use this filter... To...

Alpha Display all checks

Beta Hide NIV, NIV local, NIP, Scalar
OVFL, and Float OVFL checks

Gamma Display red and gray checks

User def Hide checks as defined in a custom
filter that you can modify

The default filter is User def. You learn more about the User def filter in
“Using the Custom Filter” on page 4-22. You can select a composite filter
from the filter menu.

User def "I

Filter all
Alpha

User def

Beta
Zamma
Undefined

To learn how the composite filters affect the display of checks:
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1 Expand the function MathUtils::Pointer_Arithmetic() in Procedural
Entities. Select Alpha from the filter menu to display all the checks for
MathUtils::Pointer_Arithmetic().

MathUtils::Pointer_ Arithmetic () has thirty checks: twenty-six green,
one red, and three orange.

2 Select Beta from the filter menu to hide the NIV local, SCAL OVFL, NIV
other, NIP, and FLOAT OVFL checks.

[3-MathUtils::Pointer_Arthmetic

Now, only eleven checks are visible: four EXC, four IDP, and three NNT.
3 Select Alpha to display all checks again.

4 Select Gamma to display only the red and gray checks.

E;}--'.'sl’,_,l s PointerArthmeticy
‘ -,i IDF. 11

Now, only one check is visible: the red IDP.

Using the Custom Filter

The custom filter is a composite filter that you define. It appears on the
composite filter menu as User def and is the default composite filter. By
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default, the custom filter hides the OBAI, NIV local, IDP, COR, IRV, NIV
other, NIP, and NTL checks as shown in the following figure.

i J H-5HR - '.;_(U J ‘3’5 TLLE J d Ass.istantl

I NI ECAL NIV FLOAT I
| GBRAL - ZDU RS UL THF o HNT lather| WIF - Q0P . EXC - gF - ASRT - HWTC | WTL - UNR . INF - UOR

COR. - FRU

IDF . CPP -

To modify the custom filter:
1 Select User def from the composite filters menu.
2 Select Edit > Custom filters.

The Custom filter setup dialog box appears.
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ECustom filter setup - PolySpace Viewer = | Ellil

Select the checks or colors to hide when the custom filter is set.

Check Filter Color Filter Variable Type Filter
¥ Dut of Bound Array Index Checks I~ Gray Checks [~ Mon-Shared Variables
[~ Zero Division Checks I~ Orange Checks
¥ Mon-Initialized Local Variable Checks I~ Green Checks
I~ Scalar Overfiow Checks [~ Errors in non executable procedures
[~ shift Amount out of Bounds or Left Operand of Left Shift Checks [~ Orange not containing additional information

[ this-pointer of function is not null Checks

[ Ilegal Dereferenced Pointer Checks
errors that are C++ related and are not covered by the EXC and OOP filters.

[~ This incdudes checks such as array size is strictly positive, typeid argument is correct, and dynamic
casts are valid.

[¥ Correctness Condition Checks

™ Function Returns a Value Checks

¥ Mon-Initialized Variable Checks rFloat / Scalar Filters
¥ Mon-Initialized Pointer Checks [ Float Checks
r errors that relate to Object Criented Programming and inheritance. [~ Scalar Chedks

This includes checks related to virtual function calls, this-peinter validity.

r errors that relate to exception handling.
Exception handling deals with the try block and exception block.

I~ Float Overflow Checks

I~ User Assertion Checks

I~ Unknown Mon-Termination of Call Checks

[ Mon-Termination of Loop Checks

I~ Unreachable Code Checks

[ informative checks induding information related to implicit and potential function calls.

[ value On Assigned (only displayed, not counted)

Ok | Apply | Cancel |

3 Clear the filters for the checks that you want to display. For example, if you
clear the Out of Bound Array Index Checks box, these checks display.

Note You do not have to change any of the selections for this tutorial.

4 Select the filters for the checks that you do not want to display.

5 Click OK to apply the changes and close the dialog box.
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PolySpace software saves the custom filter definition in the Viewer
preferences.

Using Individual Filters

You can use an individual filter to display or hide a given check category.
When a filter is enabled, that check category is not displayed. For example,
when the VOA filter is enabled, VOA checks are not displayed. When the
VOA filter is disabled, VOA checks are displayed. You can also filter by check
color. To enable or disable an individual filter, click the toggle button for that
filter on the toolbar.

Tip When you mouse over a filter button, a tooltip tells you which filter the
button is for and whether the filter is currently enabled or disabled.

To learn how an individual filter affects the display of checks:

1 Expand MathUtils::Close_To_Zero().
2 Select Alpha from the composite filters menu to display all checks.

3 Click the NIV local filter button

NIU
lazal

to hide the NIVL checks for MathUtils::Close_To_Zero().
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m =
a2 0 0

]

4 Click the NIV local filter button again to display the NIVL checks.

5 Now click the green checks filter button

~

to hide the green checks.

=R
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Note When you filter a check category, some red checks within that category
are still displayed. For example, if you filter IDP checks, IDP.11 is still
displayed under MathUtils::Pointer_ Arithmetic().
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4-28

Reviewing Results in Assistant Mode

In this section...

“What Is Assistant Mode?” on page 4-28

“Switching to Assistant Mode” on page 4-28

“Selecting the Methodology and Criterion Level” on page 4-29
“Exploring Methodology for C++” on page 4-29

“Reviewing Checks” on page 4-31

“Defining a Custom Methodology” on page 4-33

What Is Assistant Mode?

In assistant mode, PolySpace software chooses the checks for you to review
and the order in which you review them. PolySpace software presents checks
to you in this order:

1 All red checks

2 All blocks of gray checks (the first check in each unreachable function)

3 Orange checks according to the selected methodology and criterion level

You will learn about methodologies and criterion levels in “Selecting the
Methodology and Criterion Level” on page 4-29.

Switching to Assistant Mode

If the Viewer is in assistant mode, the switch mode button displays Expert.
If the Viewer is in expert mode, the switch mode button displays Assistant.
To switch from expert mode to assistant mode:

. . ' G Assistant
® (Click the Viewer’s switch mode button

The Viewer window toolbar displays controls specific to assistant mode.
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JIMethndnlngy for Model Based Designedj r— |_ Skip gray chechks 4 <§ '@}' §> [
1 2 a

The controls for assistant mode include:

® A menu for selecting the review methodology for orange checks
e A slider for selecting the criterion level within that methodology
¢ A check box for skipping gray checks

® Arrows for navigating through the reviews

Selecting the Methodology and Criterion Level

A methodology is a named configuration that defines the number of orange
checks, by category, that you review in assistant mode. Each methodology
has three criterion levels. Each level specifies the number of orange checks
for a given category. The levels correspond to different development phases
that have different review requirements. To select the methodology and level
for this tutorial:

1 Select Methodology for C++ from the methodology menu.

Methodalogy for Model Based Designedll

Methodalogy for Ada
Methodology for C

hethodalagy for C++

Methodelogy for Model Based Designed

2 If the level slider is not already at 1, move the slider to level 1.

Exploring Methodology for C++
In this part of the tutorial, you examine the configuration for Methodology
for C++. To begin:

1 Select Edit > Preferences.
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The Preferences PolySpace Viewer dialog box appears.
2 Select the Assistant configuration tab.
The configuration for Methodology for C++ appears.

On the right side of the dialog box, a table shows the number of orange
checks that you review for a given criterion and check category.

ameous : Assistant configuration i

~Mumber of checks to reviewn:
Criterion 1 Criterion 2 Criterion 3
COmman
il 2 20 AL
IS L 10 S0 AL
S-0%FL |10 a0 AL
CoR 10 10
Py = 10 AL
Pl l 10
F-o%FL = 10 20
ASRT 3 20
T2 & CH+ only
CE&| 10 20 AL
SHF 2 10 AL
IDF 10 20
P 10 20

For example, the table specifies that you review five orange ZDV checks
when you select criterion 1. The number of checks increases as you move
from criterion 1 to criterion 3, reflecting the changing review requirements
as you move through the development process.

In the lower-left part of the dialog box, the section Review threshold
criterion contains text that appears in the tooltip for the criterion slider
on the Viewer toolbar (only in assistant mode).
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Configuration set

methodology far C++

Feview threzhaold criterion
Criterion 1
Criterion 2

Criterion 3

Fresh code

it tested

Final wersion

For the configuration Methodology for C++, the criterion names are:

Criterion Name in the Tooltip
1 Fresh code

2 Unit tested

3 Final version

These names correspond to phases of the development process.

3 Click OK to close the

dialog box.

Reviewing Checks

In assistant mode, you review checks in the order in which PolySpace software

presents them:

1 All reds

2 All blocks of gray checks (the first check in each unreachable function)

Note You can skip gray checks by selecting the Skip gray checks check

box in the toolbar.

3 Orange checks according to the selected methodology and criterion level
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Earlier in this tutorial, you selected Methodology for C++, criterion 1. In this
part of the tutorial, you continue to review the checks for training.cpp using
this methodology and criterion level. To navigate through these checks:

1 In the procedural entities view (lower left), MathUtils: :Recursion(int*)
1s expanded and ZDV. 11 is displayed as the current check.

If the Viewer is displaying the message “No check currently selected” in the
upper-right portion of the window, then you will need to click the forward

arrow to go to the first check.

The source code view (lower right) displays the source for this check and
the current check view (upper right) displays information about this check.
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Note You can display the calling sequence and track review progress as
you did in “Reviewing Results in Expert Mode” on page 4-10.

2 Continue to click the forward arrow until you have gone through all of
the checks.

After the last check, a dialog box appears asking if you want to start again
from the first check.

Wrapping search x|
@ End of the set of checks under review.
Do wou wank to stark again From the First check?

Yes

3 Click No.

Defining a Custom Methodology

You cannot change the predefined methodologies, such as Methodology for
C++, but you can define your own methodology. In this part of the tutorial,
you learn how to create and use your own methodology.

To define your custom methodology:
1 Select Edit > Preferences.

The Preferences PolySpace Viewer dialog box appears.
2 Select the Assistant configuration tab.

3 Select Add a set from the menu in Configuration set.

4 In the Create a new set dialog box, enter My methodology for the name
and click Enter to close the dialog box.
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5 Under the Criterion 1 column, enter the number 1 next to IDP. This
tells PolySpace software to select up to one orange IDP for review. Poly
Space™ will not select any other orange checks for review because you are
leaving all of the other fields blank. This does not affect the red and gray
checks: the software will still present all red checks and the first check in
each unreachable function for review.

6 Click OK to save the methodology and close the dialog box.
To use My methodology:

1 Select My methodology from the methodology menu.

2 If the level slider is not already at 1, move the slider to level 1.

3 Click the forward arrow ? to review the checks.

With this methodology at criterion 1, you review the orange IDP.17 check.
You did not review IDP.17 earlier in the tutorial because the number of
orange IDP checks in Methodology for C++ criterion level 1 is zero.

4 End PolySpace Viewer by selecting File > Quit.
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Generating Reports of Verification Results

In this section...

“PolySpace Report Generator Overview” on page 4-35

“Generating Verification Reports” on page 4-36

PolySpace Report Generator Overview

The PolySpace Report Generator allows you to generate reports about your
verification results, using pre-defined report templates.

The PolySpace Report Generator provides the following report templates:

Coding Rules Report — Provides information about compliance with
JSF Coding Rules, as well as PolySpace configuration settings used for
the verification.

Developer Report — Provides information useful to developers, including
summary results, detailed lists of red, orange, and gray checks, and
PolySpace configuration settings used for the verification.

Developer with Green Checks Report — Provides the same content as
the Developer Report, but also includes a detailed list of green checks.

Quality Report — Provides information useful to quality engineers,
including summary results, statistics about the code, graphs showing
distributions of checks per file, and PolySpace configuration settings used
for the verification.

The PolySpace Report Generator allows you to generate verification reports in
the following formats:

HTML
PDF
RTF
WORD
XML
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Note WORD format is not available on UNIX platforms, RTF format is used
instead.

Generating Verification Reports

You can generate reports for any verification results using the PolySpace
Report Generator.

To generate a verification report:

1 Open your verification results in the Viewer.
2 Select Reports > Run Report.

The Run Report dialog box opens.

x

~Select Report Template

C:'\PolySpace'PolySpace_Common'\ReportGenerator itemplates\CodingRules. rpt
:\PolySpace\PolySpace_Common'ReportGenerator \templates\Developer.rpt
Ci\PalySpace\PolySpace_Common\ReportGenerator \templates \Developer_WithGreenChecks.rpt
C:\PalySpace\PaolySpace_Common'\ReportGenerator \templates \Quality rot

Browse. .. |

—Select Report Format
Qutput folder IC:'IPD|‘5I'5|:IEIIZEWE'J’\'J:IFDjEEt'I,I'ESI.IltS'IPD|‘5I'5|:IEIIZE-DDC |
Qutput format  |PDF -

Run Report | Cancel
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3 Select the type of report you want to run in the Select Report Template
section.

4 Select the Output folder in which to save the report.
5 Select the Output format for the report.
6 Click Run Report.

The software creates the specified report.
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e “About This Tutorial” on page 5-2
e “Setting Up JSF++ Checking” on page 5-3
e “Running a Verification with JSF++ Checking” on page 5-10
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About This Tutorial

In this section...

“Overview” on page 5-2

“Before You Start” on page 5-2

Overview

PolySpace software can check that C++ code complies with the Joint
Strike Fighter Air Vehicle C++ coding standards (JSF++) To check JSF++
compliance, you set an option in your project and then run a verification.
PolySpace software finds the violations during the compile phase of a
verification. When you have addressed all JSF++ violations, you run the
verification again.

For more information on the JSF C++ Checker, see “JSF C++ Checker’in the
PolySpace Products for C++ User’s Guide.

In this tutorial, you learn how to:
1 Set an option for checking JSF++ compliance.

2 Select JSF++ rules to check.

3 Run a verification with JSF++ checking.

Before You Start

For this tutorial, you check the JSF++ compliance of the file training.cpp,
using the project that you created in Chapter 2, “Setting Up a Project File”.
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Setting Up JSF++ Checking

In this section...

“Opening the Example Project” on page 5-3
“Setting the JSF++ Checking Option” on page 5-3
“Creating a JSF++ Rules File” on page 5-4
“Excluding Files from JSF++ Checking” on page 5-7
“Configuring Text and XML Editors” on page 5-8

“Saving the Project with a New Name” on page 5-9

Opening the Example Project

For this tutorial, you modify the project in training.cfg to include JSF++
checking and save the project with a new name. You use the Launcher to
modify the project.

To open the Launcher:
® Double-click the Launcher icon.
To open training.cfg:
1 Select File > Open project.
The Please select a file dialog box opens.
2 In Look in, navigate to polyspace_project.
3 Select training.cfg.

4 Click Open to open the file and close the dialog box.

Setting the JSF++ Checking Option

You set up JSF++ checking by selecting an option and then selecting the rules
to check. To set the JSF++ checking option:
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1 In the Analysis options, select Compliance with standards > Check
JSF-C++: 2005 rules.

The software displays the two JSF++ options: jsf-coding-rules and

includes-to-ignore.

[SHCheck JSF-C++: 2005 rules [
—FRules configuration
—Filez and directories to ignore

. fH=f-coding-rules
. fincludez-to-ignare

These options allow you to specify which rules to check and any files to
exclude from the checker.

2 Select the Check JSF-C++: 2005 rules check box.
Creating a JSF++ Rules File

You must have a rules file to run a verification with JSF++ checking. You
can use an existing file or create a new one. You create a new rules file for

this tutorial by:

® “Opening a New Rules File” on page 5-4
e “Setting All the Rules to Off” on page 5-6
e “Selecting the Rules to Check ” on page 5-6

Opening a New Rules File
To open a new rules file:
To create a new rules file:
1 Click the button J to the right of the Rules configuration option

2 Select File > New File.

The New File window opens, allowing you to create a new JSF++ rules
file, or open an existing file.
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File
Set the following state to all Jsf rules : IEerr - I El
Rules Error |Warning| Off Comments
JSF AY rules =
i-Mumber of rules by mode : 1 156 7
[Fl-Code Size and Complexity - Rules 1to 3
-1 Any one function {or method) will containnan i 8
-2 There shall not be any self-modifying code, i i f* Mot imolemented
-3 &l functions shall have a cyclomatic complexit] C O
[+-Fules - Rules 4 to 7
----- Terminology
[EI-Enviranment - Rules 3 to 15 oo
-3 all code shall conform to ISO/IEC 14882:2002) % [ s
-4 Only those characters specified in the C++bag i« s
--10 Values of character types will be restricted t [ = Mot imolemented
--11 Trigraphs will not be used, s [a T
--12 The following digraphs will not be used: "<%g [a T
--13 Multi-byte characters and wide string literals| [a T
--14 Literal suffixes shall use uppercase rather th) i« s
--15 Provision shall be made for run-time checking i« s
[+-Libraries - Rules 16 to 25
[+]-Pre-Processing Directives - Rules 26 to 32 LI
ok Cancel |

For each JSF++ rule, you specify one of these states:

State Causes the verification to...
Error End after the compile phase when this rule is violated.
Warning Display warning message and continue verification

when this rule is violated.

Off Skip checking of this rule.
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Note The default state for most rules is Warning. The state for rules that
have not yet been implemented is Off. Some rules always have state Error
(you cannot change the state of these).

Setting All the Rules to Off

Because this tutorial checks only a few rules, first set the state of all rules to
Off. Later, you select the rules to check.

To set the state of all rules to Off:

1 From the Set the following state to all Jsf menu, select Off .

2 Click Go.

Selecting the Rules to Check

To select the rules to check for this tutorial:
1 Expand the set of rules named Type Conversions - Rules 177 to 185.
2 Select the Warning column for rule 180.

3 Expand the set of rules names Flow Control Structures - Rules 186
to 201.

4 Select the Error column for rule 191.

5 Click OK to save the rules and close the window.
The Save as dialog box opens.

6 In File, enter jsf.txt

7 Click OK to save the file and close the dialog box.
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Excluding Files from JSF++ Checking

You can exclude files from JSF++ checking. You might want to exclude some
included files. To exclude math.h from the JSF++ checking of the project
training.cfg:

1 Click the button J to the right of the Files and directories to ignore
option.

The Files and directories to ignore (includes-to-ignore) dialog box opens.
[ x|
~Files and directories to ignore [-includes-to-ignore]

.r | - i

COPolySpacetsourcesinath b
CPolySpacetzourcesmatriz b

CPolySpacelzourcesiincludes

Ok Cancel |

2 Click the folder icon.
The Select a file or directory to include dialog box appears.
3 Navigate to the polyspace _project folder.
4 Select the includes folder.
5 Click OK.
The includes folder appears in the list of files to ignore.

6 Click OK to close the dialog box.
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Configuring Text and XML Editors

Before you check JSF++ rules, you should configure your text and XML
editors in the Launcher. Configuring text and XML editors allows you to view
source files and JSF reports directly from the JSF log in the Launcher.

To configure your text and . XML editors:
1 Select Edit > Preferences.

The Preferences dialog box opens.
2 Select the Editors tab.

The Editors tab opens.

x4
Tadls Menu I Remate | auncher
Miscellaneous I Result directory | Default directary | E drtursl Generic targets
~HML editor configuration

Specify the full path to a XML editor or use the broveze button.

¥ML Edlitar: IC:WPru:ugram FilezM=OfficelDfficel MEXCEL EXE _)l

~Text editor configuration

Specify the full psth to s text editor ar use the brovese buttan.

Text Editar: IC:IF‘rugram Filezbindows MTWACcessorieswordpad exe _)l

Specify the command line arguments for the text editar.

Arguments: I

The fallowing macros can be uzed FFILE, $LIME, FCOLUMM

Ok Apply Cancel

3 Specify an XML editor to use to view JSF++ reports.

4 Specify a Text editor to use to view source files from the Launcher logs.
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5 Click OK.

Saving the Project with a New Name
You save the project with a new name so that you do not modify training.cfg.
To save the project with the name jsf_training.cfg:

1 Select File > Save as new project.

2 In the Save the project as dialog box, navigate to polyspace_project.

3 Enter jsf_training for the Session identifier and *cfg for the type.

4 Click OK to close the dialog box.
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Running a Verification with JSF++ Checking

In this section...

“Starting the Verification” on page 5-10
“Examining the JSF Log” on page 5-11

“Opening JSF Report” on page 5-12

Starting the Verification

When you run a verification with the Check JSF-C++:2005 rules option
selected, the verification checks most of the JSF++ rules during the compile
phase. If there is a violation of a rule with state Error, the verification stops.

Note Some rules address run-time errors.

The verification stops if there is a violation of a rule with state Error.

To start the verification:

. "’ Execute |
1 Click the Execute button .

2 If you see a caution that PolySpace software will remove existing results
from the results directory, click Yes to continue and close the message
dialog box.

The verification fails because of JSF++ violations. A message dialog box
appears.

x

@ Werification process Failad
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3 Click OK.

Examining the JSF Log

To examine the JSF++ violations:

1 Click the JSF button in the log area of the Launcher window.

A list of JSF++ violations appear in the log part of the window.

Search; 44 I (33

JSF

Cotmpile

2 Click on any of the violations to see a description of the violated rule, the
full path of the file in which the violation was found, and the source code

Status| Rue |  Fle- | Lre | cal
Stats 180 training .cpp 21 [=3
i 1w training .cpp 45 19
= Full Log =
—_— 1a0 training.cpp 109 15
1a0 training.cpp 142 38

containing the violation.

Search: 44' 14
Detail
Status| Rue | Fie . | Line | col
180 raining.cpp 21 I
i Rule: 191 (Error): The break statement shall not be used (except to terminate the ca
180 raInInG.Cpp 109 15
hBD haMMQcpp 147 =5 File: C:‘“PalySpace\polyspace projecthsourceshtraining.cpp line 46 (column 19)

The log reports a violation of rule 191. A break statement is used in

Source code

training.cpp.

3 Right click the row containing the violation of rule 191 , then select Open

Source File.
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statuz| Rue |  Fier | ure | ca
180 raining .cpp 21 =3
i
180 tra %= Open Source File

180 tra Open J5F Report
'ﬁ Configure Editor

The training.cpp file opens in your text editor.

Note You must configure a text editor before you can open source files.
See “Configuring Text and XML Editors” on page 5-8.

4 Correct the JSF++ violation and run the verification again.

The verification will complete, and the results will be the same as those
from the tutorial in Chapter 3, “Running a Verification”.

Opening JSF Report
After you check JSF++ rules, you can generate an XML report containing all
the errors and warnings reported by the JSF C++ checker.

Note You must configure an XML editor before you can open a JSF report.
See “Configuring Text and XML Editors” on page 5-8..

To view the JSF report:
1 Click the JSF button in the log area of the Launcher window.
A list of JSF++ violations appears in the log part of the window.

2 Right click any row in the log, and select Open JSF Report.
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statuz| Rue |  Fier | ure | ca
k4 Faining.Cpp

180 tra %= Open Source File

-
e

-
e

180 tra Open J5F Report
"ﬁ Configure Editor

The report opens in your XML editor.

= R B Bookl - Microsoft Excel -8 Xx
Home Insert Page Layout Formulas Data Review View Add-Ins Acrobat @J - 8 X
oy T || 2a = =
j # Calibri =||@y"| S Wrap Tent General - ﬂ ﬁ B s B ? ‘:ﬁ
- EE} = == 3 Delete - @ B
Paste B I = Merge & Center = - s ||%50 00| Conditional Format Cell ’ Sort & Find &
- = 4 | =] | B merg &5 i | 78 s8] Formatting ~ as Table = Styles ~ Ej Format = || (27 Filtar~ Selact~
Clipboard ™= Font {F Alignment {F Mumber (Fi Styles Cells Editing
A B C D E F G
1 B3 Line B3 columnBl| Message
2 130 shall warning C:\PolySpace\polyspace_project\sources\training.cpp 21 8 | Implicit conversions that may result in a loss of information st
3 191 shall error C:\PolySpace\polyspace_project\sources\training.cpp 16 19 | The break statement shall not be used (except to terminate tf
4 130 shall warning C:\PolySpace\polyspace_project\sources\training.cpp 109 15 | Implicit conversions that may result in a loss of information st
5 180 shall warning C:\PolySpace\polyspace_project\sources\training.cpp 142 38 | Implicit conversions that may result in a loss of information s
6
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Using a PolySpace Project
Model File

e “About This Tutorial” on page 6-2
e “Creating a New PolySpace Project Model File” on page 6-3

® “Creating a Configuration File from a PolySpace Project Model File” on
page 6-9

® “Deleting a Generic Target from the Preferences” on page 6-12
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About This Tutorial

In this section...

“Overview” on page 6-2

“Before You Start” on page 6-2

Overview

A PolySpace project model file provides a way to save generic targets with
project information. Although you can populate a project with information,
such as source files and project options, from a project model file, you cannot
run a verification with a project model file. You must have a configuration file

to run a verification. In this tutorial, you learn how to:

1 Create a new project model file.

2 Define a generic target and save it in the project model file.
3 Create a configuration file from a project model file.

4 Delete a generic target from the Launcher preferences.
Before You Start

Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Project File”to learn about configuration files and basic Launcher operations.
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Creating a New PolySpace Project Model File

In this section...

“What Is a PolySpace Project Model File?” on page 6-3
“Creating the PolySpace Project Model File” on page 6-3

What Is a PolySpace Project Model File?

A PolySpace project model file is a project file that includes generic target
processors. A development team uses this file to share project information.
The workflow is:

1 A team leader creates a project model file (. ppm). This file has the analysis
options for the project, including generic targets.

2 The team leader distributes the .ppm file to the team.

3 A developer opens the .ppm file. From this file, PolySpace software
populates the project parameters and the generic targets in the preferences.

4 The developer adds source files, include directories, and a results directory
to the project and saves it as a configuration file (.cfg).

5 The developer launches a verification with the.cfg file.

Creating the PolySpace Project Model File

You use the PolySpace Launcher to create a PolySpace project model file.
Creating a project model file involves:

® “Opening a New Project” on page 6-4

¢ “Examining the Preferences Before Adding the Generic Target” on page 6-4
¢ “Defining the Generic Target” on page 6-5

¢ “Examining the Preferences After Adding the Generic Target” on page 6-7
® “Saving the PolySpace Project Model File” on page 6-7
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Opening a New Project
To open a new project:

1 Open the PolySpace Launcher by double-clicking the Launcher icon on
your desktop.

2 If the PolySpace Language Selection dialog box appears, select
PolySpace for C/C++ and click OK.

3 Select File > New Project.
4 In the Choose the language dialog box, select CPP and click OK to
close the dialog box.

Examining the Preferences Before Adding the Generic Target

In this step, you look at the generic targets in the preferences before you add
a generic target. Unless you previously added a generic target, the generic
targets list is empty. Later, after you add a generic target, when you look at
the generic targets in the preferences again, you will see that the generic
target you added is in the list.

To look at the generic targets in the preferences:

1 Select Edit > Preferences.

The Preferences dialog box appears.
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x|
| Generic targets

Miscellaneous | Result directory | Default directory Editors |
Tools Menu | Remote Launcher

Execution command

Menu title

E

Ok Apply Cancel

2 Select the Generic targets tab.

Unless you previously added generic targets to your preferences, the
generic targets list is empty.

3 Click Cancel to close the dialog box.

Defining the Generic Target
To define a generic target:

1 In Analysis options, expand Target/Compilation.

2 Click the down arrow to open the Target processor type menu.
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Sparc

sparc

mESk

e

i 306

c-167

----PET Generic----

3 Select mcpu...(Advanced).

The Generic target options dialog box appears.

H Generic target ophions

Enter the target name

Endianness

Char

Short

It

Lok

Long long

Float

Doubledong dauble
Paointer

Alignment

Bhits
o

i 0 i e B T i i |

16bitz=  5Zbitz  Bdhits

r

w1 e

I 0 T B B

T

IL'rl'tIe endian

r

o G B T S T

)

Save

r-u.

b 0 i T i T i i |

=l

v Sighed

Cancel

4 In Enter the target name, type targeti.
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5 Click Save to save the generic target options and close the dialog box.

Examining the Preferences After Adding the Generic Target

Now when you look at the generic targets in the preferences, you should see
the generic target that you added. To look at the generic targets list in the

preferences:
1 Select Edit > Preferences.
The Preferences dialog box appears.

2 Select the Generic targets tab.

Notice that target1 appears in the generic targets list:

x

targetl

Eclit

Remove

il Apply Cancel

3 Click Cancel to close the dialog box.

Saving the PolySpace Project Model File
To save the PolySpace project model file:

1 Select File > Save project.

6-7



6 Using a PolySpace® Project Model File

6-8

The Save the project as dialog box appears.
2 Select *.ppm from the Files of type menu.
3 In Session identifier, enter target_training.

4 Click OK to save the file and close the dialog box.

Warning The generic target that you defined in this tutorial
remains in your preferences until you delete it. Be sure to complete
the section “Deleting a Generic Target from the Preferences” on page

6-12 at the end of this tutorial.



Creating a Configuration File from a PolySpace® Project Model File

Creating a Configuration File from a PolySpace Project
Model File

In this section...

“Why You Must Have a Configuration File” on page 6-9
“Opening the Project Model File” on page 6-9
“Entering Additional Required Information” on page 6-10

“Saving the Configuration File” on page 6-10

Why You Must Have a Configuration File

In the first part of this tutorial, you created a project model file. To run a
verification, you must have a configuration file. In this part of the tutorial,
you create a configuration file from the project model file that you created
earlier. The workflow 1is:

1 Open the project model file. Opening the project model file populates the:

® Generic targets in the preferences

® Analysis options and other project information

2 Enter additional information, such as the results directory and source files.

Note If you enter the results directory and source files in the project
before you save it as a PolySpace project model file, then that information
is saved in the file and appears in the project when you open the file.

3 Save the configuration file.

Opening the Project Model File

To open the project model file:

1 Select File > Open project.

The Please select a file dialog box appears.
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2 Navigate to the polyspace_project directory.
3 In File of type:, select Project Model (*.ppm) files from the menu.
4 Select target_training.ppm and click Open.

A message appears telling you that this project has no source files.

5 Click OK to close the message dialog box.

Entering Additional Required Information
A configuration file must specify the source files and results directory.

To complete the required project information:

¢ In Results Directory, enter the results directory that you created. For
the example in this guide, it is C: \polyspace _project\results.
e Add C:\polyspace project\sources\training.cpp to the source files.

e Add C:\polyspace project\includes to the include directories.

Note For more information about adding source files and include directories
to a project, see “Creating a New Project to Verify a Class in the Training
C++ File” on page 2-10.

Saving the Configuration File

To save the configuration file:
1 Select File > Save project.

The Save the project as dialog box appears.
2 Navigate to the polyspace_project directory.
3 In Session identifier, enter training2.

4 Leave the default type as *.cfg.
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5 Click OK to save the project and close the dialog box.

Note Your preferences still include the generic target target1 . Complete
“Deleting a Generic Target from the Preferences” on page 6-12 to delete this

generic target from your preferences.
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Deleting a Generic Target from the Preferences

In this section...

“Understanding the Generic Targets Preference” on page 6-12

“Deleting the Generic Target Added in This Tutorial” on page 6-12

Understanding the Generic Targets Preference

The list of generic targets is stored as a PolySpace software preference. You
can add generic targets to the list in one of these ways:

e Edit the preferences using the PolySpace Launcher.

¢ Open a PolySpace project model file that includes generic targets.

The generic targets remain in your preferences until you delete them. You
should delete the generic target that you defined and added to you preferences
earlier in this tutorial.

Deleting the Generic Target Added in This Tutorial

To delete the generic target target1 from your preferences:

1 In Analysis options, expand Target/Compilation.

2 If Target processor type is targetl, change it to sparc (You cannot
delete a generic target if it is the target processor type for the current
project.)

3 Select Edit > Preferences.
The Preferences dialog box appears.
4 Select the Generic targets tab.
5 Select target1 from the list.
6 Click Remove.

7 Click OK to apply the change and close the dialog box.




Deleting a Generic Target from the Preferences

Note You removed the generic target target1 from your preferences,
but it is still in target_example.ppm. If you save the current project in
target_example.ppm, then target example.ppm will no longer include
targeti.
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